Nikola etree.so problems with libxml2.2

Installing Nikola works great, but you get a problem with libxml2.2

Referenced from: /Users/stephen/anaconda/envs/nikola/lib/python3.6/site-packages/lxml/etree.cpython-36m-darwin.so
    Reason: Incompatible library version: etree.cpython-36m-darwin.so requires version 12.0.0 or later, but libxml2.2.dylib provides version 10.0.0

Typing:

conda install libxml2

seems to fix the issue,why?

don’t know, don’t care … just thanking the gods of stack overflow